Midi Guitar 2 not working with studio one 6 on mac m1

I had Midi Guitar working fine in Studio One 5.5 on Windows. I recently switched to a Mac M1 and I am not able to get Midi Guitar working. I should also say that when I installed Midi Guitar only the AudioUnits version was installed, no VST.

  1. I added an Audio Track and set the input appropriately, I could hear my guitar
  2. I added the Midi guitar plugin to the Audio Track, and I could see the velocity indicator responding to my playing. I could also get sound from the built-in Midi Guitar sounds.
  3. Added an instrument track selected Midi Guitar 2 as the input; Selected New Instrument and chose Majito
    At this point, I had no sound. Monitoring was turned on for the Instrument track and it was not in Mute mode.

Any help would be great.

Assuming you used the install file for Mac…
Are vsts compatible with Mac? They will not work with the iPad version or cubasis on the iPad.

I’m on Windows, but from the Jam Origin website:

System Requirements
Mac users:
-MacOS X 10.7 and upward
-Any Dual core intel based Mac. (just about any Mac produced after 2006)
-Guitar/Audio interface

M1 silicon support is not mentioned, so I assume it’s not supported yet. Have you tried running it under Rosetta?

I posted a similar question on the 07/10/22 - Studio One 6 - Plugin missing.

It was my first post so maybe it did not make sense as no replies yet.

I have a Mac Mini M1 and opted for 16Gb of memory + 1 Tb SSD for ‘production’ work and use an old Toshiba Satellite i5 with 8G ram running Windows 10 for gigs, I am not a Windows fan for for music production and used to run Linux with Ardour prior to trying out Studio One in 2014, cannot wait for the laptop to give up and die!

For the likes of us life is not simple, to make matters worse we all have different gear and approach solutions differently.

Last week I also updated to Studio One 6 and installed it alongside Studio One 5 on my Mac M1 and fortunately left the install on my gigging Windows 10 laptop for later, good news and bad news, I can confirm that if you use the same install file as I did for the Mac M1 it does work with Studio One 5.5 and still does, so like myself that would at least give you something you can work with whilst we find a solution to our problem with Studio 6.

My download was from here, bear in mind this may have been updated since the 15/05/2022:



I have just looked at Get Info and nothing for Rosetta on Midi Guitar 2 whereas the Midi Guitar Mini app I installed does have the option, but not ticked.

This all applies to the Mac M1.

In the Studio One 5 browser MIDI Guitar 2 is listed in VST2 and MIDI Guitar Mini in AudioUnit.

In the Studio One 6 browser MIDI Guitar 2 is not listed and MIDI Guitar Mini is still in AudioUnit.

My logic now says for me to try MIDI Guitar 2 as an AudioUnit plugin even though you stated that this is what you have done, at least it will confirm the outcome on a different system.

I have just re-read your post and am not sure whether you have set the tracks up correctly, it sounds different to the way I have set it up, I will check this out later due to time constraints now, I did find a guide somewhere when I first set it up.

Out of interest there were a couple of other plugins not working in Studio One 6, I can list them later if anyone is interested, the good news is that Manda Audio have just released a new version of the MT Power Drum Kit so that one is solved for Studio One 6 on the M1 if someone else has the same problem. I use this as a super click track to be replaced with my acoustic kit live later.

Fishman have also updated TriplePlay so I will also be trying this out as an interim solution until the MG2 problem is resolved, just means the inconvenience of having to take an extra guitar (Fender/Fishman Stratocaster) out, MG2 had solved this as I can/could use any guitar as a source, even my old Line 6 Variax 500 that works seamlessly with the Helix Rack for my guitar sounds.

The other option is to use Studio One 5 for gigs to keep the use of MG2 for live work, will have to see how this works out in practice.

I will update this a.s.a.p., hope it has helped.

Thanks for the response. That is the same file I used for 5.5 and 6.0. At this point I have given up. Maybe when they release something confirmed to work with the M1 I will give it a shot, but for now I am going to try a Jamstick and see how that does.

Maybe my post was a bit convoluted trying to cover all angles.

It does work with Studio One 5 fine as I have been using it on both the Mac M1 and the Windows 10 laptop for over 5 months now without any problems.

My gut feeling is that your MG2 input track is not routed correctly to the instrument, after diner I will check out how I have routed the MIDI Guitar 2 input to the instument tracks, I have one song where I have several tracks set up for different instruments where I use MG2 as input and then activate the instruments that I wish to use either as a solo or layered sound.

So much for the diner once you go down that rabbit hole time is meaningless, a lightening strike blew my network out a while back and I have been using a usb drive to swap files between the PC’s as the NAS is on the Mac for Time Machine. I could not locate the files I wanted as I am doing a massive tidy up of drives so that they are all back in one place, the NAS drive.

Out of interest I have used my Sphere account to collaborate with myself between machines as that saves using the usb drive to swap the files until I get the new router, that is one of the reasons why I am so keen to use Studio One 6 as these features have been upgraded and I want to have a play before committing to collaborating with a friend in another country.

Okay I just set up a new blank song in Studio One 5 on the Mac M1 and this is the procedure I used to get it to work, again different to what I did before, but it worked. As mentioned before my MG2 plugin is installed as VST2 not AudioUnit.

You will have the track window now click on Mix and Browse down in the bottom right corner.

In the browser click instruments at the top and then navigate to Mojito or any other instrument then drag the icon across to the track window not the mixer window.

Above the track, top left you will see an ‘I’ just before the spanner icon, click this and an information panel will open for the instrument track and for me halfway down you will see In, Out and Channel, thus is where you choose what you need. I dragged over Mojito so Out and Channel say Mojito and the in is blank as no MG2 yet. If you have clicked Inst. on the left side of the mixer panel you will also see Mojito in the instruments panel on the left of the mixer window.

Now we want input so go to the browser and click effects at the top, navigate down to MG2 and drag the icon on to the track window, at this stage choose the input channel number for your guitar via your interface from either the track, information or mixer window, they all work the same. Click the loudspeaker icon to see the guitar working in the meter.

Now we have input to MG2 we can activate the input for the instrument Mojito by clicking on the instrument track and in the information panel go back down to the Out, In and Channel panel, In will probably say all inputs, change this to MIDI Guitar 2, again make sure that you highlight the speaker icon on the Instrument track as well.

Bingo you should naw hear Mojito triggered by MG2.

If you want to do A/B/C sound checks quickly just create more instrument track with MG2 as input and switch between them using the speaker icons, simple meerkat.

Hope you can follow that and given you something to work with until we get MG2 working with Studio One 6.

Problem solved Mike it is now working in Studio One 6 on my Mac M1.

See my earlier post 07/10/2022 for full instructions.

Can you post a link to your solution?

Hope this works I need to get up to speed on how to post, do links and indicate that the problem is solved in the heading.

Thank You! adding Midi Guitar as an external device actually worked. I still don’t see the VST version only AudioUnits, but at this point, I will take what I can get. Thanks again for the help.

I ran into a similar problem but not on a M1, even when following the instructions at MIDI Guitar: the V6 Remix - PreSonus BlogPreSonus Blog. Specifically, I could see activity in the MIDI Guitar activity view, but nothing was getting to the Instruments. The solution turned out to be: use the VST2 version of MIDI Guitar 2, NOT the AU version! I just switched from AU to VST2 and everything immediately started working w/o having to create any external device.

If you don’t see the VST2 version of MIDI Guitar 2 in the Studio One Effects browser, click on the wrench icon in the upper-right, then you should be able to see it; make sure it’s enabled. You can also hide/disable the AU version in Studio One so it’s not placed accidentally.


1 Like

While VSTs do work on Apple computers (NOT on devices running iOS!), Apple strongly suggests using AU versions wherever possible. So if one isn’t working normally the other will.

But it looks like the problem wasn’t a plugin issue of AU/VST; rather, a routing/set-up issue.