MIDIGUITAR2 difficulties in Ableton

Hi Folks, I’d consider buying this product if I could get it to work. I’ve spent two days with the demo version on my Microsoft Windows Pro laptop. I finally created a new live set and followed the instructions in video on your site for Ableton Live 9 but when I drag an instrument to the Midi track, nothing positive happens. I only get my electric guitar sound. I don’t get the new instrument sound. I see the signal is showing up in the MIDIGUITAR2 popup, but the signal never comes out of it according to the screen. In addition, the original guitar sound is making it to the Master track and coming out. I’ve played with sample rate, removed delay compensation, made sure all the track setting are like the settings in the video. Still nothing. Maybe it’s the instruments I’m dragging in. I don’t really know. Maybe I’m not playing loud enough? My DAW is a Focusrite 2i2.

Make sure everything looks like this:

Also, turn off “Direct Monitoring” on your interface

Thanks so much for responding so quickly (within 24 hours). I made the changes you suggested and tried to make my DAW look like the picture you sent me. I’m uploading a picture of my DAW so you can see my screenshot looks pretty similar to yours except for the names. Still no luck. I also turned off Direct Monitoring on interface.


Midi guitar 2 should be in track 1 with your guitar the output of which will be sent to your midi synth in track 2

Regards Max

1 Like

Thank you for your response, Max. I’m just not sure how to interpret it. I’m just a beginner. At the top of my view is the audio track GTR where I dragged in the MidiGuitar plug in. I’m hoping that’s Track 1. You can see the MidiGuitar2 plug icon below that is associated with that track. Below that is Basic Sine K, the Midi track that is taking inputs from GTR. Is that wrong? I’m not sure what to change. Thanks for your patience.

I don’t have my Ableton open, I’m on a cell phone but from your pic it looks like midi guitar 2 is in track 2. It should be where your guitar is in track 1. Track 2 should be a midi track and have have your synth plug in and set to receive input from track 1and the record button should be activated in order to monitor the synth output.

Just took a look at my computer with Ableton and your settings good. I can see from your pic now that midi guitar 2 is where it should be. Sorry you are right.

The only difference from mine is I’ve clicked on the s button on track 2 so that I only hear the synth

Check the knobs on your focus rite 2i2 to make sure your not monitoring input just output

Thanks for your responses and saying that it appears my setting are correct.

The Focusrite 2i2 has a three-toggle button on the monitor, the first click is direct, the second click is no monitor and third click is monitor after the DAW, I have it on the second click and no monitoring light is on and I can’t hear anything when strumming. When I have the MidiGuitar2 panel open, I see the sound causes a reaction on the meter. But I don’t see anything on the way out.
Maybe the instrument I picked is not an instrument or there is something wrong with it? I dragged it from the instrument rack, and it’s called Basic Sine Keys. Is that valid? I dragged it into the Midi track and it changed the title of the Midi track as expected.

the issue is that your midi track (2 basic sine k) should be set to ‘in’ instead of auto.

Thanks for your response. I see no change whether the In or Auto button is pressed.

I do notice that having the direct monitor on or the monitor after DAW processing on does stop the visual meters on application from showing any sound hits. So obviously, any monitoring throws off the processing.

But if the audio interface monitor of sound after DAW processing is off, how do I tell what sound I’m getting from the DAW? Do I have to record myself and then play back the recording to see what sound I received?

I also changed the instrument to a brass strings synth just to make sure any sound I get is way different than my electric guitar sound but of course I never hear the new sound through the headphones.

I guess the problem could be one or more of many: the audio interface (Focusrite 2i2), the DAW (Ableton 11 Live Lite), MidiGuitar2, the instrument I’ve selected (Brass Strings Synth), some computer setting or lack of power (Microsoft Surface Pro 10), or – even after everyone’s attempts to help – some other basic user error on my part. Fairly complex problem to solve for a newbie.

I’m sure the signal reaches the DAW because I’ve recorded it and played it back. I’m pretty sure the signal reaches MidiGuitar2 because I see the visual meters on the MidiGuitar2 icon lighting up, and now I even see visual meters on both sides of the instrument icon lighting up, but I never hear the new sound. I guess I could record it and then see if I’m hear the replacement sound.

Thanks for everyone’s ideas.

The only other thing I can think of right now (again not being near my computer) is your asio config in Ableton. Like buffer settings and using the Focus Rite asio drivers

why don’t we simplify and get your ableton working first before we even try midi guitar.

you will need just two tracks, both midi.

as with your previous liveset, you will set track 2 to take midi input from track one.

put the synth of your choice on track 2.

create a midi clip on track 1 (double click on an empty slot). add a note or two (double click on the bottom right).

when you play your new clip you should have audio output from track 2.

once you have this setup working it will be easy to switch it to midiguitar. if you can’t get this working, your issue is with ableton or your audio interface.

in this case, track 1 should be ‘off’ and track 2 should be ‘on’. (this is what works with live9 on win10)

if you prefer another option: use one of midi guitar’s built-in synths. if you have output, your problem is an ableton midi routing issue. if not, the problem is with midiguitar.

if that turns out to be the case, please run mg2 in standalone mode and tell us what happens.

Thanks again for quick response and giving me a troubleshooting strategy. I added two MIDIs to a new set as you suggested, creating some musical notes in Piano Roll in Session View. I have played the clip and I can hear it with the synth I selected in my headphones with direct monitoring off. I am very green at this so I’m sending a snippet in case you need to confirm that I did what you were expecting. What’s next?


before you do the next step, please play your clip and observe the midi activity on track 2. every note will flash the three vertical dots to the left of ‘Post Mixer’.

a quick note, i think on live 9 monitor would need to be in, so my experience may not apply to your situation.

in any case, next drop mg2 onto your track3 and set track3 to ‘in’. change track2’s input to track3. look for activity when you play.

if still no joy, let us know if you can run mg2 in standalone mode, try selecting one of the built-in instrument patches.

please do send more screen caps, they’re very helpful.

Thank you again for these steps. I have good news and bad news.

The good news is after making the changes you suggested, my guitar began causing the application to play the brass synthesizer instrument. So I switched the instrument to Nylon String Guitar, and again, if I hit the notes very slowly and avoid chords, the application appears to send out the correct sounds.

But of course, the bad news is if I try to play at a normal tempo, it appears that the application can’t keep up with my playing, and it loses notes randomly and doesn’t play at a steady rate. Eventually, it stops working altogether, but this may just be the MidiGuitar2 shutting down as expected in the demo version. If I click on the wrench in the MidiGuitar2 icon at the bottom of the screen and then close the ensuing popup, the application starts performing again, albeit unsatisfactorily.

I also tried Ample Sound’s lite M2, which is a free instrument plugin with some really clear, nice steel string guitar sounds. and had the same issues.

Is there any way to improve MidiGuitar2 performance in Ableton? In the standalone version, will I see better performance?

Would a more powerful computer than my Microsoft Surface 10 lead to better performance? My box has this processor: Intel(R) Core ™ i5-7200U CPU @ 2.50GHz 2.71 GHz with 8G of RAM

Here is a screenshot of the setting as you requested.

OK, so I did a few other things to see if it would improve my latency issues.

  1. I changed sample rate to 32 on my Focusrite 2i2. On one website, a person said it only needs to be 24 but I couldn’t set it that low.
  2. I went into Options on Ableton and tried turning on and off Delay compensation.
  3. I went into Options and changed one sound setting from High Quality to Normal.
  4. I switched to the Ample Guitar Sound M 2 Lite instrument plugin.
    Doing all these things made a noticeable improvement in application responses, but not enough to avoid random note drops and late responses entirely.

Bard AI, an artificial intelligence app, says I need a more powerful computer, though you have to take everything it says with a boulder of salt.

Thanks for helping me reach at least this point.

I’ve also discovered that Bitwig and Reaper, other DAWs, allow the sample bit rate to be significantly lower than the 192 bits required by Ableton Live 11 Lite. Has anyone had success with a computer like mine with either of these DAWs and a lower sample bit rate?

I see that I’ve been mixing up sample bit rates and buffers in previous message. For the record, I’m using a sample rate of 44,100 and a buffer size of 32. I can’t seem to get the buffer size any lower. I see a few other DAWs will work with a lower buffer but not sure that would help me.

I’ve turned off a bunch of stuff my computer to see if that would help. And I fiddled with the Focusrite driver settings. It’s interesting that the Focusrite driver tells you what the round-trip latency is. I even took it out of Safe mode which lowered the latency somewhat. But when I tried MidiGuitar2 and Ableton after that, latency was still a problem, though I perceived a hair of a difference in unsafe mode. Here’s a look at the Focusrite 2i2 settings in and out of safe mode so you can see what it reports as the round-trip latency.

It looks like only way I can use product is with a stronger computer.

I appreciate everyone’s help so far.