Jam Origin

MIDI Guitar & MIDI Bass user forum

Mix control not working? Anyone using RME fireface?

I’m having trouble understanding why the mix control is not working. I’m trying out the demo and using it within Cubase 7 on a PC. RME fireface interface. Any ideas?

Are you referring to the mix control on your interface or in mg2? I don’t use cubebase but in the standalone mg2, if you want to hear clean guitar along with your synth, you need to at least load the “direct” module in the guitar (blue) section. Hope this helps.

Max

Thanks for your reply Max. The mix control in mg2 is what i was referring to. I can already hear the clean guitar as well as the synth. I was trying to set things up so I could only hear the synth on its own while I am playing. The mix control should allow that if I understand it correctly but it doesn’t seem to do anything. I’m new to mg2 so I’m probably missing something obvious!

Hi David!
I have the two relevant parts of the MIDI Guitar interface marked by a red box and a blue box here. Red is for any synth/virtual instrument and effects to go with that, whereas the blue box is the Audio part of the signal chain. The MIx knob sets the balance between the two.

Now, if you have nothing open in the blue box (like in the picture) you shouldn’t have any guitar audio coming through however you set the mix knob.
If you do it is usually a “direct monitoring” setting on your audio interface that needs to be addressed.
Check these discussions out, and see if there is something in those that might help:

Thanks LoFiLeiF that is helpful. I have nothing in the blue section so I think you must be right and it’s a direct monitoring issue. I did think that might possibly be the problem but the RME fireface comes with a very elaborate routing utility and the manual is not terribly well translated from german. It also assumes you know quite a bit about mixers in the terms it uses. Anyway I couldn’t immediately find a way to disable direct monitoring which I assume must be enabled by default. I need to spend some more time trying to track it down. Unless anyone here has an RME interface and can help me out?

So I haven’t used any RME products myself, but I looked at some videos, and I think you are right to ask anyone in here already using RME for answers. (I took the liberty of adding to your question title to perhaps get the message across a little). Hopefully, we’ll get an answer quickly enough!

Hello @dbee, welcome here :slightly_smiling_face:

The first thing to do is to familiarize yourself with Totalmix which is the essential tool for using an RME interface.

In the meantime, to check if you can play in MG2:

  • insert “Direct” in the first AMP/FX window of MG2
  • in Totalmix select the input where your guitar is plugged in (in this picture I’m plugged in input 4), click on the tool symbol (circled in yellow) to expand the settings menu, set the gain (circled in red) to about 7 to start with (that’s the input level of your guitar), and above all: set the fader level (circled in green) to 0, that’s the direct return of the sound of your guitar which should not be audible when you go through a software.

If this still doesn’t work, you will have to continue adjusting the RME settings in Totalmix.

To learn how to use Totalmix, which is fundamental to use an RME, go on this link which will propose you a series of 12 very well done videos: https://www.youtube.com/watch?v=ZkxzYlBiScA&list=PL0QKeSpeDQwHGxAhD-cJSIBZC7_en5rck

EDIT: forgot Totalmix screenshot :thinking:

1 Like

Herold than you. That is very helpful. Totalmix is incredibly flexible but not at all intuitive. I’m slightly nervous of it because I once managed to disable audio entirely and it took me nearly a week to get it restored! Anyway it looks like I need to get to grips with it properly. I will check out those videos.

For sure Totalmix is not intuitive, but once you have explored it, it becomes easy and convenient to use (at least for basic applications).

Look at Totalmix in a simplistic way:

  • the top row represents the physical inputs
  • the bottom row represents the physical outputs
  • the middle row represents everything else for record and playback: daw, media players, MG2, etc.
  • the Control Room (on the bottom right)) is where you assign the main outs and headphones.

From there on everything becomes easier to understand.
And again, take the time to watch the videos over and over again to get a solid foundation.
Follow this other link to start well with the videos: How To Use RME TotalMix FX

Herold, I understand the basic concepts of totalmix but there are far too many hidden functions and the manual is hopeless. One of the main issues is that it duplicates many of the routing features already available in the DAW so you end up with a routing matrix in the DAW interacting with another routing matrix in totalmix which is incredibly confusing when trying to track something down that should be easy - like direct monitoring. Even the answer to someone else’s question on the same topic under one of the RME videos is confusing. When asked about disabling direct monitoring they refer you to a different mixer configuration called DAW mode but don’t actually specify whether this disables direct monitoring. The idea that totalmix settings all change whenever you click on a different channel on the bottom row is madness. Anyway I do appreciate your links and I will sort it out eventually!

AArgh! The RME solution to disabling direct mode shows different menu’s than I have in my version of totalmix! The DAW mode they refer to does not exist in my software!

OK finally worked it out thanks to the help of Herold and some trial and error in totalmix. It requires different settings in totalmix than the ones I usually use to record which is inconvenient but it does work.
Thanks for the help here I could have gone round in circles for a lot longer without it!

1 Like

Glad to hear it, now if you have any questions about MG2, we’ll be even happier to talk about it :wink:

1 Like